Pelion // EE Roaming issue // Degraded Performance

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that this incident has been resolved.

We apologise for any inconvenience.
Posted Nov 18, 2025 - 16:43 GMT

Monitoring

Status:
Monitoring

EE have identified and implemented a resolution and Pelion have seen a recovery in our monitoring graphs; we are monitoring the resolution to ensure no further impact for this incident is experienced.

Customer action required:
Customers may have to restart their devices in the first instance if they do not automatically recover.

We apologise for any inconvenience.
Posted Nov 18, 2025 - 13:56 GMT

Investigating

Status: Investigating Incident

Service Impacted:
Tele2 / Three IE / Pelion Global Roaming (JT)

Priority:
High

Pelion Environment Area(s) Affected:
UK

Summary:

Pelion Support teams are currently investigating issues with roaming SIMs that are roaming in the UK under EE.
Pelion's network partner has advised they are seeing network registration issues on the EE network in the UK.
Subscribers may need several attempts to register for the network, affecting SMS, Voice and Data services.

Update:
Pelion has seen the trend of online and offline devices roaming in the UK decline but this is now increasing.

Please use any other available network in the UK as an alternative.


We will provide an update shortly and we apologise for any inconvenience.
Posted Nov 18, 2025 - 11:39 GMT
This incident affected: Mobile Operators (Pelion Global Roaming, EE, Tele2, Three IRE).