Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2026 - 23:00 BST
Scheduled
Tele2 will be carrying out essential maintenance on 15/09/2026 between 23:00 and 05:00 BST.
During this time Tele2 will be performing service-affecting emergency maintenance on its VoLTE (IMS) infrastructure to maintain service quality and reliability.
Start Date and time: 15/09/2026 23:00 BST
End Date and time: 16/09/2026 05:00 BST
Services affected: • During this planned Maintenance Window, there is going to be an impact of up to 4 minutes for VoLTE services for Tele2 subscribers, affecting new registrations and call setups. No impact on ongoing calls or registrations. • No impact to any other services (Data, SMS, or regular Voice) is expected.
Customer action required: No customer action is required.
Posted Sep 11, 2026 - 19:09 BST
This scheduled maintenance affected: Mobile Operators (Tele2).