Three UK
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 14:40 GMT
Monitoring
We have identified and implemented a fix, we are continuing to monitor to ensure no further impact.

Customer action required: None
Posted Aug 14, 2020 - 16:54 BST
Update
We are continuing to work on a fix for this issue however some impact may still be seen.
We are still working to fully resolve the issue.
Posted Aug 14, 2020 - 10:28 BST
Update
We are aware of further issues impacting ThreeUK This morning, Our Engineering team is continuing to investigate this as a priority
Posted Aug 13, 2020 - 11:42 BST
Update
We have mitigated the issues which were impacting devices connecting to the network, we will be continuing with our network improvement plan to reduce the chance of this reoccurring.
Posted Aug 12, 2020 - 10:39 BST
Update
We are continuing to work on a fix for this issue however some impact where devices may disconnect and reconnect, may still be seen.
We are still working to fully investigate and resolve the issues and a planned maintenance window is in place for this evening 11/08/20 18:00 - 20:00 to work on the issues.
Thank you for your patience and apologies for any inconvenience caused.
Posted Aug 11, 2020 - 15:43 BST
Update
We are continuing to work on a fix for this issue however some impact may still be seen.
We are still working to fully resolve the issue.
Posted Aug 11, 2020 - 10:52 BST
Update
We are continuing to work on a fix for this issue however some impact may still be seen.
We are still working to fully resolve the issue.
Posted Aug 10, 2020 - 14:30 BST
Identified
We are continuing to work on a fix for this issue however some impact may still be seen.
We are working to fully resolve the issue and we will provide an update shortly.
Posted Aug 10, 2020 - 10:38 BST
Update
We are continuing to work on a fix for this issue however some impact may still be seen.
We are working to fully resolve the issue and we will provide an update shortly.
Posted Aug 10, 2020 - 10:37 BST
Update
We have identified and implemented a fix, we are continuing to monitor to ensure no further impact

Customer action required: No customer action is required, however if you do believe that you have impacted devices then please fully power cycle/restart your device in the first instance.
Posted Aug 07, 2020 - 18:25 BST
Monitoring
We have identified and implemented a fix, we are continuing to monitor to ensure no further impact

Customer action required: No customer action is required, however if you do believe that you have impacted devices then please fully power cycle/restart your device in the first instance.
Posted Aug 07, 2020 - 18:19 BST
Update
We are continuing to work on a fix for this issue.
We have mitigated the issue, however some impact may still be seen.
We are working to fully resolve the issue and we will provide an update shortly.
Posted Aug 07, 2020 - 16:40 BST
Identified
Please be advised that we are aware of further impact seen on Three UK SIM's, this is being investigated and we will provide an update shortly.
Posted Aug 07, 2020 - 14:19 BST
Monitoring
This incident has been resolved under monitoring.

Customer action required: No customer action is required, however if you do believe that you have impacted devices then please fully power cycle/restart your device in the first instance. If you still require support, please raise a ticket via the normal channels.
Posted Aug 07, 2020 - 12:24 BST
Investigating
We have identified an issue with SIM's on Three UK.
Please be advised that this is being investigated and we will provide an update shortly.
Posted Aug 07, 2020 - 11:00 BST
This incident affected: Mobile Operators (Three UK).