Three UK Delay in Processing Provisioning
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 10:41 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2020 - 09:08 BST
Investigating
Three UK have notified us of a possible delay with provisioning new and existing SIM's.
Please avoid activating new and making changes to Three UK SIM's.
Further updates to follow shortly.
Posted Jun 03, 2020 - 09:08 BST
This incident affected: Mobile Operators (Three UK).